Calculate section

From HEPMDB
Jump to: navigation, search

The Calculate section of HEPMDB is accessible only if you are registered. This wiki page will enable you to use the HEPMDB computation frame in order to produce events and compute cross-sections using the various models on the website.

The interface

The interface is divided into four parts:

  1. The top bar, containing the HEPMDB logo, the Show Iridis4 Queue and Go to Main Site buttons, and a drop down menu.
  2. The messages box, with general information on the last operations.
  3. The left menu, with the main functions and the program list.
  4. The calculation part, presenting results of computation.

The top bar

In the top bar, you will find:

  • A Show Iridis4 Queue button that opens a window showing information on the total use of Iridis4 and the job queue for HEPMDB itself.
  • A drop down menu.
  • The Go to Main Site button which redirects you to the HEPMDB main page in the same tab.


The drop down menu contains a few useful items:

  • User ID: This is very useful to reference if ever asking one of the developers about a problem with your account.
  • Documentation: This takes you to these Wiki pages in a new tab.
  • History: This opens a window with a full list of everything you have done on HEPMDB.
  • Send a message to admin: This opens a window allowing you to send a message to an admin with your registered email.
  • Reset Account: This will clear all your imported models and your .lhe and .nt files, and restore your account to its default settings.

The messages box

This part of the webpage displays information on any actions you have performed. For example, starting a job will display a message stating whether or not the job has been successfully submitted and the time of submission. The Check Job Progress button, located in the menus of CalcHEP, Whizard and Madgraph, will display any information on currently running jobs (like expected completion time) in the message box also.

The left menu

This is one of the most important menus in HEPMDB. This is where the commands to prepare, run and view the result files of a process are stored. The menu is divided into three panels. Each panel corresponds to a specific program for computing matrix elements. CalcHEP and WHIZARD work essentially the same way. There are some subtle differences for MadGraph.

The calculation part

When the computation is done, the results will be displayed here. In the case of an error, the debugging information is also displayed here.

Using CalcHEP

Here, we will review the basic steps for a CalcHEP computation.

You can find a complete tutorial specifically for CalcHEP HERE.

Choosing a model

When using CalcHEP, the first thing you have to do is make sure that the model you wish to use is imported. If it is imported, you will see it in the left panel. If it is not there, click on the Import model option of the File drop-down menu. You can import any model that has been uploaded to HEPMDB and shared publicly, or any you have uploaded and not shared.

When the model you wish to use is imported (when you can see it in the left panel) choose it by selecting it. You are now ready to work with that model.

The batch file

On HEPMDB, you use the batch mode of CalcHEP. The batch file can be edited through the Edit batch file option in the Selection drop down menu.

Besides writing the batch, you have four options in the editing window:

  1. Save Changes: This does not save to a file! Instead, it tells HEPMDB to use the written batch file for computation.
  2. Import Full Template: This is a very useful option which loads the template file. The template file contains every possible option as well as some commented out sections which describe various parts of the batch file. Simply change the variables/values so that it calculates what you require and save it.
  3. Load Batch: This allows the user to load the batch file from a file.
  4. Save As: This option saves the current batch to a file. You still have to use the Save Changes button to tell HEPMDB to use the batch file.

Running

Once you have saved your batch file (making sure to have used the Save Changes button), you can now select Run Batch File from the Selection drop-down menu. You can check the status of the queued process via Check Job Progress in the File menu.

When you select Run Batch File a window should appear asking you to confirm the job submission. In this window it is possible to change the requested HPCx usage time (the current default is 10 minutes). Asking for a smaller amount of time will give your job a higher priority. However, it is important to note that if your job is still running at the end of the requested time it will be killed and returned to you with anything it managed in that time. Users are also limited to a request of 60 hours maximum.

Results

When the computation is done HEPMDB will notify you by email. When you receive this email you can return to the Calculate Section of HEPMDB to view your results. If your results are not automatically displayed click again on the Check Job Progress button from the File drop-down menu and they should be now be displayed in the main window. Any previous results can been reviewed using the history option found in the Tools menu.

In the main window you can see the total cross section for your process as well as the cross section for the sub-processes. If a parameter scan was asked for, a table of the cross sections for each value of the parameter will be listed first, followed by separate tables of the cross sections for the sub-processes for each parameter value. The number of events for each (sub)process is also listed. These same tables can be viewed by selecting View Run Folder from the File drop-down menu.

Kinematical distributions can be plotted via the View LHE and NT folder from the File drop-down menu. Before plotting, the desired file must be uncompressed via the new File menu in the current window. This will make two files, one is in the Les Houches Accord format (.lhe) while the other is in the PAW N-tuples format (.nt). For plotting on HEPMDB the file format does not matter, select a file and click Plot! from the top of the window. Now the kinematical variable that you wish to plot and the desired particles can be selected from the respective drop down menu. The particles are defined by their PDG number which can be found by clicking on View Particles in the Selection drop down menu (not while the View LHE and NT folder and Plot! windows are open). Once the plot is produced it can be downloaded as a picture in various formats, or as data in a text file. After clicking on the Download button you must OK the confirmation message and then click on the file name in the message box that will have popped up in the bottom right corner of your browser window to start the download.

Using WHIZARD

This only covers basic help. More comprehensive help is to come.

Choosing a model

On HEPMDB, WHIZARD usage is very similar to CalcHEP's. You first have to import a model and choose it. Note that the WHIZARD models available to use are a lot less numerous than those on CalcHEP. Please upload your own models if you need to. You can import the model via the Import model button then select it in the list in order to use it.

The batch file

The batch file can be edited through the Edit batch file option.

Besides writing the batch, you have four options in the editing window:

  1. Load batch template: This is very useful as it loads a template file that contains every possible option. You then change the variables/values to suit your calculation.
  2. Load from: This enables you to load a batch file from a file.
  3. Save: This does not save to a file! But it tells HEPMDB to use the written batch file for computation.
  4. Save As: This only saves to a file. You still have to use the Save button to tell HEPMDB to use the batch file.

Running

To run WHIZARD, select the Run Whizard option. You then have the choice between queuing or not. It is recommended that you choose to queue the calculation, especially for long computation as that allows you to close your internet browser while it is running.

If the job time set by the user is under 2 hours, the calculation will be given priority on HEPMDB.

Using MadGraph

MadGraph works slightly differently. Once again, more comprehensive help should be available soon. If the help you require is not available here, please search for MadGraph specific help on the internet.

MadGraph cards

MadGraph works with cards. There are four different cards each having a particular role:

  1. proc_card_mg5.dat: This defines the processes to be processed.
  2. param_card.dat: This holds the parameters about the model (decays, branching ratios). Note that this file is overwritten by MadGraph after event generation.
  3. run_card.dat: In this file, you define the parameters for the run, for example the energy of the beam or which pdf to use.
  4. plot_card.dat: With MadGraph it is possible to automatically produce some plots. But with the HEPMDB toolkit and lhe file, this is of little use.

For all of these files, templates are available, so you do not have to know every parameter. Filling these files and checking the different parameters should be enough in most cases.

Running

For running, just use the Run Madgraph button. For now, there is no queuing system for MadGraph so you must stay connected to HEPMDB website while computing.

If the job time set by the user is under 2 hours, the calculation will be given priority on HEPMDB.